Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-16393

Clarify which browsers are officially supported for style authors

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Closed
    • Affects Version/s: 3.2.8, 3.2.9, 3.3.0
    • Fix Version/s: None
    • Component/s: Documentation
    • Labels:

      Description

      According to the current Styles Submission Policy for phpBB 3.2 and 3.3, "Submissions must be compatible with Internet Explorer 9 (and above) and Firefox". That statement suggests to the style authors that IE9 and Firefox are the officially supported browsers by phpBB. However, I find some problems with that guideline.

       

      1) Internet Explorer support

      Although IE9, released in 2011 for Windows Vista, 7 and Server 2008, seems to be still officially supported (despite its tiny share market), the reality tells another story.

      One year ago, at the time of phpBB 3.2.5, I reported a bug which occurs with IE9. I don't know if a non-Microsoft browser is also affected, but that flaw is still unresolved, suggesting that fixing an issue related to IE9 is not a high priority, while it's "officially" supported by phpBB 3.2+.

      Worse, since phpBB 3.2.8, the file assets/javascript/plupload.js returns an error on IE9 (; expected) in the message editor. As a result, the "place inline" button no longer works.

      Finally, since phpBB 3.3.0, the image files styles/prosilver/theme/images/bg_header.gif and styles/prosilver/theme/images/bg_list.gif are removed. These files are useful to get gradient backgrounds for IE9 (the CSS property background: linear-gradient needs at least IE10). Oddly, these removed images are still invoked by theme/tweaks.css (the existence of that css file, invoked itself by overall_header.html and simple_header.html template files, suggests IE9 is still supported).

      Apparently, the support of IE9 and even IE10 has been dropped since phpBB 3.2.2 but the Style Submission Policy has never been updated to reflect that change.

       

      2) Firefox support

      "Firefox" is far too imprecise. Which versions? The first version released in 2004 is still supported? Or Firefox 4, came out in 2011 like IE9? On January 2017, someone stated phpBB 3.2.0 supported IE9+ and the latest 2 browsers for all others, but the style submission policy has never indicated which Firefox versions are supported.

       

      3) Other browsers support

      What about Blink/Webkit-based browsers? Today, the vast majory of internet users have installed Google Chrome on your computer but phpBB team seems to ignore it, at least according to the style submission policy.

       

      The guideline is surely outdated and incomplete. It doesn't reflect the actual policy of phpBB team in 2020.

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Big Monstro Big Monstro
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: