Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-15933

The redirected URL after posting/editing can be incomplete (without anchor)

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.2.5
    • Fix Version/s: None
    • Component/s: Attachments, Posting
    • Labels:
      None

      Description

      Since phpBB 3.1, users are immediately redirected to their posts after posting or editing. With the older and discontinued phpBB 3.0, a message was displayed to confirm the posting or editing and, then, users were redirected to their posts.

      Normally, users are redirected to viewtopic.php?f=XX&t=YY&p=ZZ#pZZ, to reach the exact position of their post in the page. However, in some circumstances, they are redirected to viewtopic.php?f=XX&t=YY&p=ZZ (without the anchor). As a result, they go to the top of the page. We can experience that issue if the attachment is enabled (+ you have the permission to attach files) and older Internet Explorer is used. Someone has noticed it in the past with phpBB 3.0 and a mod so that the board behaves like phpBB 3.1+, and he or she suggested it's related to Content-Type of the post-form (https://www.phpbb.com/community/viewtopic.php?t=2098651)

      With pbpBB 3.2.x, I encountered the issue in IE9, which is still supported by phpBB team (see Styles Submission Policy) and by Microsoft (on Windows Server 2008). Perhaps IE10 and some non-Microsoft browsers are also affected (not tested).

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Big Monstro Big Monstro
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: