Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-15909

v310\bot_update.php migration attempts to invoke 3.2.x user_delete and fails because oauth_states table has not been added yet.

    Details

      Description

      User attempting 3.0.x to 3.2.4 upgrade using full installation package hits the failure described in https://www.phpbb.com/community/viewtopic.php?f=556&t=2495021

      The 3.2.x user_delete function, when enumerating the auth providers, is expecting to check the oauth_states table which appears to have been added in 3.2.x.  But at the point the v310\bot_update.php migration module is running, this table hasn't been added yet when the starting version is before 3.1.x.

      The issue is avoided by many/most users, ostensibly, because either they don't encounter any bots that need to be deleted, or because they upgrade from 3.0.x to 3.1.x first, and then from 3.1.x to 3.2.x.  Which "steps over the hole" where oauth_states table would be referenced during user_delete but doesn't exist yet.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                EA117 EA117
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: