Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12407

Allow changing of post_data and other variables with core.posting_modify_template_vars

    Details

    • Type: Improvement
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-b2
    • Fix Version/s: 3.1.0-b4
    • Component/s: Events
    • Labels:
      None

      Description

      The current event core.posting_modify_template_vars is just ran using dispatch but it doesn't pass any data from posting.php to the listener. Because of that, it's not possible to know anything from posting.php and therefore limits the use cases of this event. It should be changed to allow similar actions as with the event core.modify_posting_parameters.

        Activity

        rfdy rfdy added a comment -

        This is a duplicate of PHPBB3-12391


          People

          • Assignee:
            Marc Marc
            Reporter:
            Marc Marc
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development