Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-10631 Extensions Admin
  3. PHPBB3-10817

Use valid composer.json instead of non-standard extension.json

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Component/s: Extensions
    • Labels:
      None

      Description

      We should simply use the composer.json format and also call the file that? It seems like our current file is pretty much that anyway. A specifiation of the format, that already exists then: http://getcomposer.org/doc/04-schema.md

      I've also created an issue for allowing the definition of a role for authors: https://github.com/composer/composer/issues/581

      Discussion on Area51: http://area51.phpbb.com/phpBB/viewtopic.php?f=84&t=42567&p=237865#p237865

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                imkingdavid David King
                Reporter:
                naderman Nils Adermann
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: