Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-9950

Problem with localized button images after uprading from 3.0.7-PL1 to 3.0.8

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0.8
    • Fix Version/s: 3.0.9-RC1
    • Component/s: Styles
    • Labels:
      None
    • Environment:
      PHP 5.2.14, MySQL 5.1.47, Firefox 3.6.12, IE 8, Opera 10.63

      Description

      After upgrading from 3.0.7-PL1 to 3.0.8 in the following phpBB setup:

      -Default Forum Language: Greek
      -User Default Language: English
      -Template is Prosilver and Prosilver-based Odyssey

      I noticed that the localized button images do not display well. Specifically:

      -If I do not log in and go to forum, I will see the button images in Greek (which is correct)
      -If I log in with a user whose language is English, I will continue to see the image in Greek. The only way to get the proper image (ie English) is to hit refresh in the browser.
      -If I log out, the images are not returning to Greek, but they remain in English from the last user session. Once again, I have to hit refresh button to get them back to Greek.

      The issue is described in full here:

      http://www.phpbb.com/community/viewtopic.php?f=46&t=2112518

      I also recorded a video that I used a previous backup of my database (3.0.7-PL1 backup) where everything works fine and I upgrade this perfectly working installation to 3.0.8. After the upgrade the installation displays the problem described above. The links for the videos are:

      Part 1/2:
      http://www.youtube.com/watch?v=shbac19cnek

      Part 2/2:
      http://www.youtube.com/watch?v=sVhG2s4hpgk

      The videos should be viewed in 480p since the original resolution is 640*480.

      Full length video (WMV):
      http://rapidshare.com/files/437881760/phpBB3.wmv

      PS. In 3.0.6, there was a problem with button images. It was fixed in 3.0.7-PL1 but a new problem exists in 3.0.8).

      PS2. I verified the problem with a clean installation of 3.0.8 (ie with a blank.default DB)

        Issue Links

          Activity

          ToonArmy Chris Smith added a comment -

          We should just totally pull out any dependency on the SID and use the passed parameters, which means reverse caches can cache the stylesheet with no unexpected surprises.

          ToonArmy Chris Smith added a comment -

          The problem is the anonymous user is pulling it's language from the users table instead of the config table, generating the wrong URL and caching the wrong content. As a workaround go into the ACP, edit the anonymous user and set its language to match the board default language.

          ToonArmy Chris Smith added a comment -

          <me2_> "The problem is the anonymous user is pulling it's language from the users table instead of the config table"
          <me2_> that is incorrect, anonymous always uses the config value, the user preference is irrelevant

          The point is that when the stylesheet language is placed in the URL it should use $config['default_lang'] it doesn't it always uses $user->data['user_lang'] so if you adjust the anonymous users language to match your default it will workaround this problem.

          manicx manicx added a comment -

          Hi Chris, thanks for your reply. In the original post in my support forum, I mentioned the Anonymous lang workaround. I am currently having the Anonymous set to the default Forum lang because the problem is annoying and several users reported it to me. I hope it is fixed in future phpBB release.

          ToonArmy Chris Smith added a comment -

          I didn't see you'd mentioned the workaround, I only glanced over the topic. This will be fixed for 3.0.9.

          naderman Nils Adermann added a comment -

          Instead of using $user->data['user_lang'] This patch uses $user->lang_name in page_header. $user->lang_name contains the actual computed language so the URLs will reference the correct version of style.php and caching is no longer an issue.


            People

            • Assignee:
              naderman Nils Adermann
              Reporter:
              manicx manicx
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development