Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-9933

Wrong handling of consecutive multiple asterisks in word censor

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.8
    • Fix Version/s: 3.0.9-RC1
    • Component/s: ACP
    • Labels:
      None

      Description

      When you put a word with multiple (>2) consecutive asterisks in word censor for replacement, it causes errors like

      [phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 712: preg_replace(): Compilation failed: nothing to repeat at offset 25
      [phpBB Debug] PHP Notice: in file /includes/functions_content.php on line 712: preg_replace(): Compilation failed: nothing to repeat at offset 25


      Regression is caused by the fix for PHPBB3-6747.

        Issue Links

          Activity

          bantu Andreas Fischer added a comment -

          Additional changes required.


            People

            • Assignee:
              bantu Andreas Fischer
              Reporter:
              rxu Ruslan Uzdenov
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development