Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-9928

Do not link "login to your board" to the "send statistics" page after completed update.

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.8
    • Fix Version/s: 3.0.9-RC1
    • Component/s: None
    • Labels:
      None
    • Environment:
      N/A

      Description

      When the update with the automatic updater has finished, it presents you with 2 links, with the language var 'ALL_FILES_UP_TO_DATE'
      Both links in this var are the same:
      ../ucp.php?mode=login&redirect=adm/index.php%3Fi=send_statistics%26mode=send_statistics

      While this is good for the second link, the first link should just redirect one to the login page, without the send_statistics. People who don't want to send these statistics are now misled.

        Activity

        Hide
        nickvergessen Joas Schilling added a comment -

        The statistics are not send automatically...

        Show
        nickvergessen Joas Schilling added a comment - The statistics are not send automatically...
        Hide
        narqelion narqelion [X] (Inactive) added a comment -

        This is a valid bug, Trivial though not Major.

        @nickvergessen, the statistics not being sent automatically is not the point of this bug report, the fact that the update confirmation screen/language contains the wrong link for the login is.

        The 'login to your board' and 'Send Statistics' links in the following screen are both

        <a href="../ucp.php?mode=login&amp;redirect=adm/index.php%3Fi=send_statistics%26mode=send_statistics">

        when in fact the 'login to your board' should be

        <a href="../ucp.php?mode=login">


        Patch attached.

        Show
        narqelion narqelion [X] (Inactive) added a comment - This is a valid bug, Trivial though not Major. @nickvergessen, the statistics not being sent automatically is not the point of this bug report, the fact that the update confirmation screen/language contains the wrong link for the login is. The 'login to your board' and 'Send Statistics' links in the following screen are both <a href="../ucp.php?mode=login&amp;redirect=adm/index.php%3Fi=send_statistics%26mode=send_statistics"> when in fact the 'login to your board' should be <a href="../ucp.php?mode=login"> Patch attached.
        Hide
        bantu Andreas Fischer added a comment -

        Not "major" because statistics aren't sent by just clicking on the link.

        Show
        bantu Andreas Fischer added a comment - Not "major" because statistics aren't sent by just clicking on the link.
        Hide
        AdamR Adam Reyher added a comment -

        Since the previous patch was deleted...

        Show
        AdamR Adam Reyher added a comment - Since the previous patch was deleted...

          People

          • Assignee:
            bantu Andreas Fischer
            Reporter:
            Ger Ger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development