Details

    • Type: Task
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.8-RC1
    • Component/s: None
    • Labels:
      None

      Description

      The unit tests in develop-olympus do not display notices. Notices should be enabled to make sure we don't miss anything.

        Issue Links

          Activity

          naderman Nils Adermann added a comment -

          They are displayed just fine for me. Can you please run a test with $x[ABC] for example and see if it really doesn't show the notice?

          naderman Nils Adermann added a comment -

          Well I do get the problem in that particular test. Something else must be at fault here.

          naderman Nils Adermann added a comment -

          Alright finally figured out what this was caused by: When the template's display() method triggered an error / threw an exception the error level would not be reset afterwards. Added a catch clause now where it gets reset. That should work. Not an issue in 3.1 since that should have NOTICE-free templates.


            People

            • Assignee:
              naderman Nils Adermann
              Reporter:
              bantu Andreas Fischer
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development