Uploaded image for project: 'phpBB'
  1. phpBB
  2. PHPBB-9673 Compatibility with HipHop
  3. PHPBB-9670

Remove use of eval() from includes/functions_module.php

    XMLWordPrintable

Details

    • Sub-task
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Invalid
    • 3.0.7-PL1
    • 3.1.0-b4
    • Other
    • None

    Description

      Use of eval in the module_auth() function breaks compatibility with HipHop. Remove the use of eval and replace it with a custom parser that does not rely on eval.

      Since this results in a performance hit, introduce a system where modules may implement their auth logic in php and degrade to parsing only when necessary. This patch should be followed up with patches to introduce native php auth checks.

      Attachments

        Activity

          People

            nickvergessen Joas Schilling [X] (Inactive)
            ckwalsh Cullen Walsh [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: