Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-9495

Loginbox <input /> redirect breaks xHTML

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.x
    • Fix Version/s: 3.0.8-RC1
    • Component/s: Other
    • Labels:
      None
    • Environment:
      PHP Environment:
      Database:

      Description

      When you view the login box, for example on http://127.0.0.1/phpBB3/viewtopic.php?f=2&p=7#p7 after logging in you are redirected to the topic. Therefor the redirect parameter is added in the template:

      <input type="hidden" name="redirect" value="./viewtopic.php?f=2&p=7" />

      but the & should be & Now it is invalid XHTML:

      Line 184, Column 67: general entity "p" not defined and no default entity
      		<input type="hidden" name="redirect" value="./viewtopic.php?f=2&p=7" />
       
      This is usually a cascading error caused by a an undefined entity reference or use of an unencoded ampersand (&) in an URL or body text. See the previous message for further details.
      

        Activity

        Hide
        nickvergessen Joas Schilling added a comment -

        This is not fixed?!

        Show
        nickvergessen Joas Schilling added a comment - This is not fixed?!
        Hide
        Kellanved Kellanved [X] (Inactive) added a comment -

        I don't see how this is not fixed.

        Show
        Kellanved Kellanved [X] (Inactive) added a comment - I don't see how this is not fixed.

          People

          • Assignee:
            Kellanved Kellanved [X] (Inactive)
            Reporter:
            nickvergessen Joas Schilling
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development