Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-9100

Inline attachments are not being inserted at the cursor

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.7
    • Fix Version/s: 3.1.3-RC1
    • Component/s: Posting
    • Labels:
      None

      Description

      The version is actually 3.0.7 but I can't select 3.0.7 from the drop down.

      Anyway, let's say I do some typing in the posting entry screen. I then upload an image to insert into the post. I upload the image but when I hit the enter key a few times (moving the cursor down in the posting screen) then click on "Place in-line" the file will be placed directly after the last entry instead of where the cursor is positioned...I get the same effect on here.

      Minor really but annoying none the less.

        Activity

        Hide
        bantu Andreas Fischer added a comment -

        What browser are you using?

        Show
        bantu Andreas Fischer added a comment - What browser are you using?
        Hide
        RMcGirr83 Rich McGirr added a comment -

        Chrome

        Show
        RMcGirr83 Rich McGirr added a comment - Chrome
        Hide
        stevemaury stevemaury added a comment -

        Same thing with Firefox, but it also happened in 3.0.6.

        Show
        stevemaury stevemaury added a comment - Same thing with Firefox, but it also happened in 3.0.6.
        Hide
        callum95 callum95 added a comment -

        Replicated in Safari. I wasn't testing with inline attachments, it affected everything.

        Show
        callum95 callum95 added a comment - Replicated in Safari. I wasn't testing with inline attachments, it affected everything.
        Hide
        callum95 callum95 added a comment -

        reproduced in safari 5.0.5, OS X Snow Leopard: http://www.youtube.com/watch?v=EzDwXFKi0Sg

        Show
        callum95 callum95 added a comment - reproduced in safari 5.0.5, OS X Snow Leopard: http://www.youtube.com/watch?v=EzDwXFKi0Sg
        Hide
        bantu Andreas Fischer added a comment - - edited

        Can not reproduce on 3.0.9 with Firefox 6.

        Show
        bantu Andreas Fischer added a comment - - edited Can not reproduce on 3.0.9 with Firefox 6.
        Hide
        D¡cky Richard Foote [X] (Inactive) added a comment -

        Reproduced on 3.0.9 with Firefox 5.0. It did work fine with the explanation that Rich gave to reproduce. I experienced the problem by hitting Enter a few times, adding the file and immediately placing inline. It worked fine when I added the file, placed the cursor in the text area where I wanted the attachment then placed inline. So, the problem seems to occur when there is a lack of focus in the text area.

        Show
        D¡cky Richard Foote [X] (Inactive) added a comment - Reproduced on 3.0.9 with Firefox 5.0. It did work fine with the explanation that Rich gave to reproduce. I experienced the problem by hitting Enter a few times, adding the file and immediately placing inline. It worked fine when I added the file, placed the cursor in the text area where I wanted the attachment then placed inline. So, the problem seems to occur when there is a lack of focus in the text area.
        Hide
        nickvergessen Joas Schilling added a comment -

        Seems to be fixed with the new attachment uploader

        Show
        nickvergessen Joas Schilling added a comment - Seems to be fixed with the new attachment uploader

          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            RMcGirr83 Rich McGirr
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development