Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-8960

Allow changing allow_avatar_remote when images/avatars/upload is not writable

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.6
    • Fix Version/s: 3.0.13-RC1, 3.1.0-b3
    • Component/s: ACP
    • Labels:
      None

      Description

      In ACP -> Configuration -> Avatar
      you can't change options if chmod of avatar path isn't writable.

      It isn't correct because you can want use, for example, only gallery and chmod of avatar path isn't important

        Issue Links

          Activity

          bantu Andreas Fischer added a comment -

          The phpBB installer makes sure the avatar path is writable. Still suboptimal, but not major. Decreasing to minor.

          bantu Andreas Fischer added a comment -

          Because avatar upload is a totally optional feature, the check in the ACP and the check in the installer should both be adjusted.

          nickvergessen Joas Schilling added a comment -

          Marc is this fixed in 3.1?

          Marc Marc added a comment -

          This is actually caused by the input type rwpath. If the supplied path is not writable the function validate_config_vars() will always return an error which prevents us from changing the settings.
          I'm not sure what would be the best way to treat this.

          naderman Nils Adermann added a comment -

          Merged this now, can certainly come up with a better way of displaying a warning about this.


            People

            • Assignee:
              Marc Marc
              Reporter:
              AleSSaNDRo AleSSaNDRo
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development