Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-8929

MS SQL error on view all smilies after 3.0.6 upgrade

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0.6
    • Fix Version/s: 3.0.8-RC1
    • Component/s: Posting
    • Labels:
      None
    • Environment:
      PHP Environment:
      Database: MS SQL

      Description

      What version of phpBB are you using? phpBB 3.0.6
      What is your board's URL? http://www.roverstalk.com
      Who do you host your board with? self-hosted
      How did you install your board? I used the download package from phpBB.com
      Is your board a fresh install or a conversion? Conversion from phpBB2
      Do you have any MODs installed? Yes
      Is registration required to reproduce this issue? Yes
      What MODs do you have installed? antibotquestion
      What styles do you currently have installed? minimal
      What language(s) is your board currently using? English
      Which database type/version are you using? MS SQL Server
      What is your level of experience? New to PHP but not phpBB
      What username can be used to view this issue? test
      What password can be used to view this issue? testtest
      When did your problem begin? After upgrade to 3.0.6
      Please describe your problem. When clicking to 'View more smilies' the following SQL error is displayed: -

      SQL ERROR [ mssql_odbc ]

      [Microsoft][ODBC SQL Server Driver][SQL Server]Column name 'phpbb_smilies.smiley_order' is invalid in the ORDER BY clause because it is not contained in either an aggregate function or the GROUP BY clause. [37000]

      SQL

      SELECT TOP 50 smiley_url, MIN(emotion) as emotion, MIN(code) AS code, smiley_width, smiley_height FROM phpbb_smilies GROUP BY smiley_url, smiley_width, smiley_height ORDER BY smiley_order

      BACKTRACE

      FILE: includes/db/mssql_odbc.php
      LINE: 165
      CALL: dbal->sql_error()

      FILE: includes/db/mssql_odbc.php
      LINE: 217
      CALL: dbal_mssql_odbc->sql_query()

      FILE: includes/db/dbal.php
      LINE: 170
      CALL: dbal_mssql_odbc->_sql_query_limit()

      FILE: includes/functions_posting.php
      LINE: 92
      CALL: dbal->sql_query_limit()

      FILE: posting.php
      LINE: 133
      CALL: generate_smilies()

      While I can easily fix this I wondered if it had been picked up already.

        Issue Links

          Activity

          Paul Paul Sohier added a comment -

          In the next release probarly, 3.0.8

          ToonArmy Chris Smith added a comment -

          MySQL regression reported here: [bug:2czci38l]58585[/bug:2czci38l]

          altni altni added a comment -

          Thanks folks, the sql fix above worked for me with MySQL 4.

          error [11111]

          altni altni added a comment -

          oops should have said, error appeared after upgrading from 306 to 307 pl1

          ahac2 ahac2 added a comment -

          The fix above fixes the error (mysql 4) and shows some smilies but not all (I have many added).


            People

            • Assignee:
              aptx aptx
              Reporter:
              ethiaa ethiaa
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development