Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-8912

phpbb_styles_template_data contans more than 4k records

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.5
    • Fix Version/s: 3.1.0-a1
    • Component/s: Other
    • Labels:
      None
    • Environment:
      PHP Environment: 5
      Database: 5

      Description

      Is it OK so many records? Template files are less then 200, and so many records. Why?

      Another problem is that when I am trying to export templates it contans dozens of duplicates: http://www.sendspace.com/file/ixoezf

        Issue Links

          Activity

          bantu Andreas Fischer added a comment -

          Please take this to the support forums first to find the cause of it. Feel free to reply here if you have indeed found a bug.

          dialer dialer added a comment -

          Well, I made a descision of my problems and I want you developers to take a look at it. I think we can make phpbb little more better (see my last post)
          http://www.phpbb.com/community/viewtopic.php?f=46&t=1887385&p=11414245#p11414245

          nickvergessen Joas Schilling added a comment -

          The nice problem on this is, that this should not even do anything, as the template is only stored, if it is not already with the same filename and template_id in the database. Maybe you should just finish your update to 3.0.6 and see whether the problem continues. If so, just change from database-stored to file-stored in ACP > Styles > Template > Details

          dialer dialer added a comment -

          I have already finished updating to 3.0.6 and we are curriently testing all the things. And the problem did not disappeared and I switchet to file storage. This solution is OK for us, because we do not what to store it in DB, actually. We always wanted to make less loading to DB an this is the good case to do it

          orthello orthello added a comment -

          Templates also seem to exist multiple times in the export. I choose to download the .zip export.
          Breadcrumbs.html exists 140 times and in only two versions. 139 times with CRC: D1A6B4B7 and just 1 time with CRC: D96D161F. (see attachment)
          When unpacking an overwrite confirmation is popping up. Which is to be expected in this case.

          Same thing happens when exporting templates to a .tar or .zip in /store

          Please advice
          Using phpBB 3.0.6
          Did the auto update from 3.0.4 to 3.0.6
          I don't know if this behaviour was present before the update.


            People

            • Assignee:
              bantu Andreas Fischer
              Reporter:
              dialer dialer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development