Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-8526

Uploads of special JPGs as attachment Bug

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Resolution: Fixed
    • Affects Version/s: 3.0.5
    • Fix Version/s: 3.0.6
    • Component/s: Posting
    • Labels:
      None
    • Environment:
      PHP Environment: 5.2.5
      Database:

      Description

      Uploads of special JPGs as attachments trigger a debug-message:

      [phpBB Debug] PHP Notice: in file /includes/functions_posting.php on line 848: imagecopyresampled(): supplied argument is not a valid Image resource

      While creating a totally black preview-picture, the JPG-file itself is uploaded without any problems.

      I assume that this error only occurs in 1 from 1000 JPG-files, I can send the original to a team-member privately for inspection.

      A total description of this matter is posted in support-forum:
      http://www.phpbb.com/community/viewtopic.php?p=10325495#p10325495

      BTW: This same debug-message also occurs on phpbb.com by trying to upload this file.

        Attachments

          Activity

            People

            • Assignee:
              bantu Andreas Fischer
              Reporter:
              updown updown [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: