Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-8499

Emoticons are not always inserted where the cursor is

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Resolution: Won't Fix
    • Affects Version/s: 3.0.5
    • Fix Version/s: None
    • Component/s: Posting
    • Labels:
      None
    • Environment:
      PHP Environment: 5.2.6
      Database: MySQL 5.0.67

      Description

      When you write something in the post form, press "enter" a number of times and then click an emoticon, it's not inserted in the last line, where the insertion cursor is positioned, but in the first blank line instead.

      It happens only when done exactly as I said. If you press enter many times, move the cursor around with the arrow keys and just then click an emoticon, it works as it's supposed to.

      This problem can be noticed on phpBB's own forum. I suppose it's a JavaScript glitch, so I'm including some browser-related information below.

      The person who reported this to me is running Google Chrome 2.0.172.37 on Windows XP and I was able to reproduce it on Safari 4.0.2 running on Mac OS X Leopard.

      User agents:
      Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.5 (KHTML, like Gecko) Chrome/2.0.172.37 Safari/530.5
      Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/530.19.2 (KHTML, like Gecko) Version/4.0.2 Safari/530.19

        Attachments

          Activity

            People

            • Assignee:
              Acyd Burn Meik Sievertsen [X] (Inactive)
              Reporter:
              tom-riddle tom-riddle [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: