Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-8250

Forum selections in MCP queue not working

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.4
    • Fix Version/s: 3.1.4-RC1
    • Labels:
      None
    • Environment:
      PHP Environment: 5.2.9
      Database: MySQL 5.0.75

      Description

      in MCP -> Moderation Queue -> both topics and posts

      -> 'Approve Details' for any topic/post
      -> (dis-)approve topic/post
      -> confirm
      -> return link sends you back and sets the forum_id (var 'f') to the one of the post/topic you just (dis-)approved
      -> only topics/posts from that forum should be displayed: instead there are no topics/posts at all (not even from that very forum)
      -> switch back to "All forums"
      -> topics/posts appear again
      

        Activity

        Hide
        Acyd Burn Meik Sievertsen [X] (Inactive) added a comment -

        For me additional non-approved posts are displayed, from the forum.

        Show
        Acyd Burn Meik Sievertsen [X] (Inactive) added a comment - For me additional non-approved posts are displayed, from the forum.
        Hide
        vindex vindex [X] (Inactive) added a comment -

        Ok I noticed the problem behind it:

        If you select a forum from the drop-down-box, the var(f) is submitted via POST, but the GET['f'] remains the same in the url.
        So if you change the forum via drop-down and then click again on one of the options "Topics/Posts awaiting for approval", the original selected forum (not the one you chose via drop-down) will be used as filter.

        -> Solution would be to make the drop-down-submit change the f= in the url, too!

        Show
        vindex vindex [X] (Inactive) added a comment - Ok I noticed the problem behind it: If you select a forum from the drop-down-box, the var(f) is submitted via POST, but the GET ['f'] remains the same in the url. So if you change the forum via drop-down and then click again on one of the options "Topics/Posts awaiting for approval", the original selected forum (not the one you chose via drop-down) will be used as filter. -> Solution would be to make the drop-down-submit change the f= in the url, too!
        Hide
        suitlocal suitlocal [X] (Inactive) added a comment -

        i canot reproduce problem either. your second post mention drop-down box. your first post does not mention that. if i change forum, select post, and hit (dis-)approve button i am taken back to moderation queue for same forum that i was at before. i am not taken to redirect forum from drop-down box. which is the correct behavior i believe. if you want to change forum click on Go button - not on (dis-)approve button.

        i propose this bug be closed as invalid.

        Show
        suitlocal suitlocal [X] (Inactive) added a comment - i canot reproduce problem either. your second post mention drop-down box. your first post does not mention that. if i change forum, select post, and hit (dis-)approve button i am taken back to moderation queue for same forum that i was at before. i am not taken to redirect forum from drop-down box. which is the correct behavior i believe. if you want to change forum click on Go button - not on (dis-)approve button. i propose this bug be closed as invalid.
        Hide
        nickvergessen Joas Schilling added a comment -

        Fixed in 3.1 since we changed the jumpbox to get

        Show
        nickvergessen Joas Schilling added a comment - Fixed in 3.1 since we changed the jumpbox to get

          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            vindex vindex [X] (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development