Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-7215

Installation schema assumes auto_increment will start at 1, increment by 1

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 3.0.1
    • Fix Version/s: 3.1.0-b1
    • Component/s: Installation system
    • Labels:
      None
    • Environment:
      Database: MySQL 5.0.46

      Description

      During installation, the schema that gets used to create the tables and populate them with initial data does not specify id's for certain fields, but later refers to those entries assuming that the id's inserted into an auto_increment field will start at 1 and increment by 1. This is not always the case – for example, when MySQL is setup in a Master-Master replication setting, the auto_increment settings will be setup so that the two servers don't have conflicting auto_increment numbers. For example, a MySQL server may be setup to start an auto_increment column at 2 and increment by 3 each insert.

      The schema used for the phpBB install causes the forum to be unusable after a standard install when the MySQL server is setup this way.

      I am attaching a patch to the schema file which sets the _id fields where needed. I have tested this out on one MySQL db where the auto increment settings are as follows:
      auto_increment_increment = 3
      auto_increment_offset = 2

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                nickvergessen Joas Schilling [X] (Inactive)
                Reporter:
                JeffIsGood JeffIsGood [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: