Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.x
    • Fix Version/s: 3.0.9-RC1
    • Component/s: Posting
    • Labels:
      None

      Description

      When using a [ url ] BBCode tag whose text content spans multiple lines, the regex will not match and convert to markup accordingly.

      Please refer to this test post in the development forums for an example.

        Issue Links

          Activity

          flxf flxf added a comment -

          Patch revised.

          For any matches with invalid urls as in the example given by Meik, ignores first [url] tag and attempts to rematch from the subsequent [url] tag if it exists.

          rxu Ruslan Uzdenov added a comment - - edited

          Thanks for the patch.
          The problem I see in it is that it's targeted on the particukar text braking problem, thus it's not universal. For example, it brakes the link text here

          test [url=http://www.phpbb.com/]test
          [url]http://phpbb.com[/url] test


          The point is that we need universal solution that won't brake the text for the most of cases.

          flxf flxf added a comment -

          The problem is that, as noted above, there is an absence of a standard to how to parse the bbcode in a 'standard' way. The fact of the matter is that the cases given above, it is bad input and we have undefined behaviour. Arguably, my patch produces 'a' parse that works. Do want that the inner-most tags take precedence?

          naderman Nils Adermann added a comment -

          The github pull request states that the patch needs more fixing, so reopening. Please provide a new patch.

          rxu Ruslan Uzdenov added a comment -

          The fix has been adjusted, also tests for url bbcode have been added.


            People

            • Assignee:
              rxu Ruslan Uzdenov
              Reporter:
              curtisj curtisj
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development