Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-16549

Use PHPUnit 9.3+ for PHP 8.0+ tests

    Details

    • Type: Improvement
    • Status: Patch Awaiting Review (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 4.0.0-a1, 3.3.1-RC1
    • Fix Version/s: None
    • Component/s: Test Suite
    • Labels:
      None

      Description

      As of match expressions RFC got merged into PHP 8.0+, PHPUnit versions earlier than 9.3-dev aren't compatible with PHP 8, see https://github.com/sebastianbergmann/phpunit/pull/4374#issuecomment-657029594

      Hence, PHPUnit 9.3-dev and higher should be used for PHP 8.0+/nightly tests.

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              rxu rxu
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: