Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-16316

navbar_header.html of prosilver style breaks Rich-Markup

    Details

      Description

      Changes made in navbar_header.html for the prosilver phpBB 3.3 release are breaking the markup validation. Testing the current code results in this:

      https://search.google.com/test/rich-results?id=AHn4uoC6-sqJzrivHMvoHg

       

      To fix the issue this code:

      	<ul id="nav-breadcrumbs" class="nav-breadcrumbs linklist navlinks" role="menubar">
      		<!-- DEFINE $MICRODATA = ' itemtype="http://schema.org/ListItem" itemprop="itemListElement" itemscope' -->
      		{% set navlink_position = 1 %}
      		<!-- EVENT overall_header_breadcrumbs_before -->
      		<li class="breadcrumbs" itemscope itemtype="http://schema.org/BreadcrumbList">
      			<!-- IF U_SITE_HOME -->
      				<span class="crumb" {$MICRODATA}><a href="{U_SITE_HOME}" itemtype="https://schema.org/Thing" itemscope itemprop="item" data-navbar-reference="home"><i class="icon fa-home fa-fw" aria-hidden="true"></i><span itemprop="name">{L_SITE_HOME}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
      			<!-- ENDIF -->
      			<!-- EVENT overall_header_breadcrumb_prepend -->
      				<span class="crumb" {$MICRODATA}><a href="{U_INDEX}" itemtype="https://schema.org/Thing" itemscope itemprop="item" accesskey="h" data-navbar-reference="index"><!-- IF not U_SITE_HOME --><i class="icon fa-home fa-fw"></i><!-- ENDIF --><span itemprop="name">{L_INDEX}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
       
      			<!-- BEGIN navlinks -->
      				{% set NAVLINK_NAME = navlinks.BREADCRUMB_NAME | default(navlinks.FORUM_NAME) %}
      				{% set NAVLINK_LINK = navlinks.U_BREADCRUMB | default(navlinks.U_VIEW_FORUM) %}
      				<!-- EVENT overall_header_navlink_prepend -->
      				<span class="crumb" {$MICRODATA}<!-- IF navlinks.MICRODATA --> {navlinks.MICRODATA}<!-- ENDIF -->><a href="{{ NAVLINK_LINK }}" itemtype="https://schema.org/Thing" itemscope itemprop="item"><span itemprop="name">{{ NAVLINK_NAME }}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
      				<!-- EVENT overall_header_navlink_append -->
      			<!-- END navlinks -->
      			<!-- EVENT overall_header_breadcrumb_append -->
      		</li>
      		<!-- EVENT overall_header_breadcrumbs_after -->
       
      		<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
      			<li class="rightside responsive-search">
      				<a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}" role="menuitem">
      					<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH}</span>
      				</a>
      			</li>
      		<!-- ENDIF -->
      	</ul>
      

      must be replaced by:

      	<ul id="nav-breadcrumbs" class="nav-breadcrumbs linklist navlinks" role="menubar">
      		<!-- DEFINE $MICRODATA = ' itemtype="http://schema.org/ListItem" itemprop="itemListElement" itemscope' -->
      		{% set navlink_position = 1 %}
      		<!-- EVENT overall_header_breadcrumbs_before -->
      		<li class="breadcrumbs" itemscope itemtype="http://schema.org/BreadcrumbList">
      			<!-- IF U_SITE_HOME -->
      				<span class="crumb" {$MICRODATA}><a href="{U_SITE_HOME}" itemprop="item" data-navbar-reference="home"><i class="icon fa-home fa-fw" aria-hidden="true"></i><span itemprop="name">{L_SITE_HOME}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
      			<!-- ENDIF -->
      			<!-- EVENT overall_header_breadcrumb_prepend -->
      				<span class="crumb" {$MICRODATA}><a href="{U_INDEX}" itemprop="item" accesskey="h" data-navbar-reference="index"><!-- IF not U_SITE_HOME --><i class="icon fa-home fa-fw"></i><!-- ENDIF --><span itemprop="name">{L_INDEX}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
       
      			<!-- BEGIN navlinks -->
      				{% set NAVLINK_NAME = navlinks.BREADCRUMB_NAME | default(navlinks.FORUM_NAME) %}
      				{% set NAVLINK_LINK = navlinks.U_BREADCRUMB | default(navlinks.U_VIEW_FORUM) %}
      				<!-- EVENT overall_header_navlink_prepend -->
      				<span class="crumb" {$MICRODATA}<!-- IF navlinks.MICRODATA --> {navlinks.MICRODATA}<!-- ENDIF -->><a href="{{ NAVLINK_LINK }}" itemprop="item"><span itemprop="name">{{ NAVLINK_NAME }}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
      				<!-- EVENT overall_header_navlink_append -->
      			<!-- END navlinks -->
      			<!-- EVENT overall_header_breadcrumb_append -->
      		</li>
      		<!-- EVENT overall_header_breadcrumbs_after -->
       
      		<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
      			<li class="rightside responsive-search">
      				<a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}" role="menuitem">
      					<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH}</span>
      				</a>
      			</li>
      		<!-- ENDIF -->
      	</ul>
      

      In other words: The 3 instances of 

      itemtype="https://schema.org/Thing" itemscope 
      

      must be removed from the file. Then everything is fine again.

       

      Also discussed on the forums here:

      https://www.phpbb.com/community/viewtopic.php?f=661&t=2535776

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Marc Marc
                Reporter:
                jackennils jackennils
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: