Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-15920

Topic Read Mine icon doesn't display accurately in older topics.

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.1.12, 3.2.5
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      PHP 5.6.39, MySQL 5.6.41, FireFox 64.0

      Description

      I've always wondered about this small malfunction that I've noticed with the post icons when it comes to the topic icons. 

      It seems that this particular icon is not always very consistent: Topic Read Mine icon – it seems to work only for newer topics that either I started or only participated.  But if I go browsing my older topics in the forum, it will only show the Topic Read icon, but not the one with the little star/asterisk icon.

      This situation seems to be like this for as long as I remember (I've been using phpBB since 2005 – not sure if this bug was around since then...), plus it also affects the community forum at phpbb.com

      If you select the Quick Links option: Your Posts ,  it will highlight correctly the newer topics that you've started or participated in, but then it will not highlight the older topics that you started or participated in the same way.

      Below I provided two screenshots from doing a "Your Posts" search at phpbb.com so you can see yourself.  NOTE: The one that displays correctly the icon, are posts found within recent posts within the search, but once I go navigate to the older posts in the search, they don't show the same icon.

      Perhaps this is not a bug?  Perhaps there is a perfect explanation why it's a hit and miss with the "Mine" icons?

      I did try conducting a search for this issue in the forum and elsewhere, but could not find anything.  Hopefully, this is a bug and perhaps it can be fixed?  Or perhaps a better explanation can be offered why this happens?

      I wouldn't of stumble upon it myself, if I didn't customize the icons myself for some of my boards to spot this inconsistency?  Perhaps this may be the reason why nobody has really noticed this odd situation?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              M.O.B. M.O.B.
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: