Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-15728

While creating custom bbCode, only one <source> tag gets parsed to the final html.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: 3.2.2
    • Fix Version/s: None
    • Component/s: BBCode Engine
    • Labels:
      None
    • Environment:
      PHP 7.1.18
      MySQL(i) 5.7.22
      phpBB 3.2.2

      Description

      Hello! While creating my forum, I was creating custom bbCodes to implement in posts. These bbcodes allowed me to insert a <video> element to play our videos in a post. I am using them in such a way to embed a Mediaelement player as our html5 player. I am using the quality selector plugin with it, so I need multiple <source> tags that point to various files. In phpbb 3.2 if I inspect the video element in a post, only one <source> tag shows. I tried this code on a custom bbcode on the phpbb 3.2 demo

      <div>
      <video>
      <source src="source1">
      <source src="source2">
      </video>
      </div>

      However, trying this same code on phpBB 3.1 demo works perfectly. I believe something may have changed in the bbCode Engine to cause this, but may be wrong. Can anyone verify this is indeed a bug and not an intended feature?

      tl;dr I feel I didn't explain this well enough, I'll make a video showing my issue in case I'm not being clear.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ryan77627 ryan77627
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: