Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-15641

Creating native search index fails if enable fulltext updating is No

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.2.2
    • Fix Version/s: None
    • Component/s: Search
    • Labels:
      None

      Description

      I migrated a client from phpBB 3.0 to 3.2. This involved moving the database offsite and converting it there and to simplify things I truncated the search tables planning to rebuild it afterward. So when uploading the database, these tables were empty. I then tried to create the search index and noticed it was almost instantaneous. I got an error message that said it still didn't exist, and when I looked at the search index interface it said zero posts were indexed. I did not understand why so I used a MySQL index instead. But it didn't seem to stick.

      When trying to create a post, it did not succeed either. User gets "The specified search backend doesn’t exist" error message. The search index doesn't exist because it is empty and creating the search index effectively failed because of the search setting.

      I think that if the search index is empty and this setting is set to No, a full index should be created. It was very confusing to figure out what the root problem and misleading too.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              MarkDHamill MarkDHamill
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: