Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-15369

Bump composer dependency version

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.3
    • Fix Version/s: 4.0.0-a1
    • Component/s: None
    • Labels:
      None

      Description

      I would like to bump composer/composer requirement from ^1.0 to ^1.5

       

      There is a conflict between phpBB/master and EPV/master which I discovered while running EPV tests on an extension with phpBB's master branch.

       

      For whatever reason EPV requires composer/composer ^1.5

      phpBB requires composer/composer ^1.0

       

      This results in a failure for EPV to be installed in phpBB because the version of composer already required by phpBB is too old for what EPV needs. You get an error like:

      Problem 1
          - Installation request for phpbb/epv dev-master -> satisfiable by phpbb/epv[dev-master].
          - Conclusion: don't install composer/composer 1.5.2
          - Can only install one of: composer/composer[1.5.0, 1.4.2].
          - Can only install one of: composer/composer[1.5.0, 1.4.2].
          - Can only install one of: composer/composer[1.5.0, 1.4.2].
          - phpbb/epv dev-master requires composer/composer ^1.5 -> satisfiable by composer/composer[1.5.0, 1.5.1, 1.5.2].
          - Conclusion: don't install composer/composer 1.5.1
          - Installation request for composer/composer (locked at 1.4.2, required as ^1.0) -> satisfiable by composer/composer[1.4.2].

       

      Also, it's very simple to reproduce the error just by running the following local commands (simulates how Travis sets up the test environment for EPV):

      git clone --depth=1 "git://github.com/phpbb/phpbb.git" "phpBB3" --branch=master
       
      cd phpBB3/phpBB
       
      php ../composer.phar install --dev --no-interaction
       
      php ../composer.phar remove sami/sami --dev --no-interaction
       
      php ../composer.phar require phpbb/epv:dev-master --dev --no-interaction --ignore-platform-reqs

        Attachments

          Activity

            People

            • Assignee:
              Marc Marc
              Reporter:
              VSE Matt Friedman
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: