Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-15077

Feed - Link to feed source is wrong

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: 3.2.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      Currently a feed shows two link tags in the feed header. One pointing to the current feed itself and another pointing to the home url of the forum.
      The second link should rather point to the source of the feed, i.e. a forum.

      See the following example:
      http://area51.phpbb.com/phpBB/feed/forum/126

      <feed xml:lang="en-gb" xmlns="http://www.w3.org/2005/Atom">
        <link rel="self" type="application/atom+xml" href="http://area51.phpbb.com/phpBB/feed/forum/126"/>
        <title>Development Discussion Board</title>
        <subtitle>phpBB's testing ground of bleeding edge developmental code</subtitle>
        <link href="http://area51.phpbb.com/phpBB/index.php"/>
        <updated>2017-02-05T10:53:42</updated>
        <author>
          <name><![CDATA[Development Discussion Board]]></name>
        </author>
        <id>http://area51.phpbb.com/phpBB/feed/forum/126</id>
      ...
      

      Wrong:

      http://area51.phpbb.com/phpBB/index.php


      Correct:

      http://area51.phpbb.com/phpBB/viewforum.php?f=126

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            MichaelMa MichaelMa [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: