Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-14898

Encoding of img tags for inline images has changed in 3.2.0

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.2.0-RC2
    • Fix Version/s: None
    • Component/s: BBCode Engine
    • Labels:
      None

      Description

      I am developing the camosslimageproxy extension, and it has been noticed that the extension does not work properly on a v3.2.0 board.

      I have isolated the issue to being that when an in-line html image tag is written to the template array in 3.1.x it has the format:
      <img src=\"http://i42.photobucket.com/albums/e318/adnil11/Vince/oiu.jpg\" class=\"postimage\" alt=\"Image\"/>

      but in 3.2.0-RC2 it is:
      <img src=\"http://i42.photobucket.com/albums/e318/adnil11/Vince/oiu.jpg\" class=\"postimage\" alt=\"Image\">

      The difference is the /> or > at the end.

      I guess that this has changed with the change of BBCode engine, I want to check whether it is expected or a bug, so I know whether to modify the extension source code or not.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              v12mike v12mike
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: