Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-14211

Improve Composer dependency versions on semantic versioned projects

    Details

    • Type: Improvement
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.1.6
    • Fix Version/s: None
    • Component/s: Build System
    • Labels:
      None

      Description

      To make phpbb more compatible when used with other / custom applications the versioning on dependencies which use semantic versioning should be improved.

      Symfony is using semantic versioning since 2.3 so we could switch from current implementation (3.1.x branch)

      composer.json

      ...
      "symfony/console": "2.3.*",
      ...
      

      to

      composer.json

      ...
      "symfony/console": "~2.3",
      ...
      

      See: ~ operator for those don't knowing the operator

      For standalone installations there is still the composer.lock file which makes sure when using `composer install` that only the tested components are loaded (symfony 2.3.*).

      But when using phpbb combined with another application which relies on symfony ~2.7 for example composer would still be able to resolve the dependencies and phpbb should still function as expected since symfony 2.7 is backwards compatible to 2.3

      This is not only 3.1.6 related but I didn't want to select all versions for an improvement.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Daniel84 Daniel84 [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: