Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-14103

Underline in abbreviations in Firefox 40

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 3.1.5, 3.2.0-dev
    • Fix Version/s: 3.1.6-RC1
    • Component/s: Styles
    • Labels:
      None

      Description

      Firefox added underline to default style of abbr element, which is different from its old behavior and behavior of other browsers. Underline isn't in css reset so this change affects all abbr elements in style (easiest one to spot is time zone abbreviation in footer navigation).

      Underline should be removed for consistent layout across browsers.

        Activity

        Arty Vjacheslav Trushkin added a comment -

        Stop messing with my ticket. This is NOT your ticket and just because you disagree with solution doesn't mean you have right to change it. That's developer's job.

        ...and that is a bug that should be fixed.

        You don't understand what is and what isn't a bug. Not following recommendation is not a bug. Inconsistent layout in browsers is a bug.

        In this case removing underline is a better solution because abbreviation in footer is irrelevant, regardless of recommendations. Time zone abbreviation is irrelevant. Forum visitors are interested in forum content, not links in footer. Underlining abbreviation in footer changes layout of that element to stand out from the rest, which makes footer a bit uglier.

        Thank you, phpBB.com user #5926, for the nice reply to another contributor!

        You seem to not understand your place. You are not developer, you are not team member, you are not person who created ticket, you are just random person who disagrees with something. Everyone is entitled to their opinions. That doesn't give you right to mess with this ticket. Its up to developers to decide what they want to do, not to you. You are just an idiot who blindly follows someone else's recommendations without thinking for himself.

        Marc Marc added a comment -

        LavIgor You should've read this part: http://www.w3.org/TR/html5/rendering.html#rendering
        It clearly states that this is not how the

        <abbr>

        should look but rather how it should be rendered by the browser. This is to ensure that designers can expect the same output on any browser that follows these recommendations. Since we want this without underline, adding an underline is obviously the WRONG approach.

        There has been a somewhat heated discussion in this ticket. Please refrain from changing the status of tickets or submitting revised pull requests as a method of "winning" a discussion for yourself. Maybe contact a developer if you feel the solution is incorrect next time.

        I expect both of you to stop commenting on this ticket unless it's an actual bug introduced by it (which there isn't as far as I can see right now).

        LavIgor LavIgor added a comment -

        @Marc, I'm extremely shocked by replies from a Styles team member.
        I'm not absolutely against removing the underline, but the ticket author (who is also not an official developer) has wrong solution to the problem.

        If underlining should be removed too, you should also remove border-bottom in the ACP style.
        Otherwise the suggested solution introduces inconsistency across browsers.
        Now Firefox 40 will be the only browser without underlining for <abbr> elements in the ACP just because its border is not removed in admin.css.

        I am strongly convinced that one bug shouldn't be fixed by introducing another one.

        Arty Vjacheslav Trushkin added a comment - - edited

        If underlining should be removed too, you should also remove border-bottom in the ACP style.

        abbr is not used anywhere in admin panel. The rest of your message is based on wrong assumption.

        Actually, that's another bug. CSS reset in ACP hasn't been updated for ages. But there is hanakin's PR with new reset that can later be applied to ACP to fix that.

        Marc Marc added a comment -

        There is no bug introduced by this and this also doesn't add any inconsistency as far as I can see.
        Please take a look at this PR for the new style reset: https://github.com/phpbb/phpbb/pull/3840

        This is the last time that I'm going to repeat myself:

        I expect both of you to stop commenting on this ticket unless it's an actual bug introduced by it (which there isn't as far as I can see right now).


          People

          • Assignee:
            Marc Marc
            Reporter:
            Arty Vjacheslav Trushkin
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development