Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13823

Update package is missing file with inline whitespace changes

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.4
    • Fix Version/s: 3.1.5-RC1
    • Component/s: Update system
    • Labels:
      None

      Description

      https://www.phpbb.com/community/posting.php?mode=reply&f=64&t=2313946#pr14066991

      Hi,

      between phpBB 3.1.3 and 3.1.4 https://github.com/phpbb/phpbb/compare/release-3.1.3...005c27e73d2cd8b6e60eaf09ebc670ce8693f3b4#files_bucket
      there are 106 files updated (without /docs/ & /install/ folders).

      Why in the next archives there are 105 files ?
      https://www.phpbb.com/downloads/?mode=update&version=3.1.3
      https://www.phpbb.com/downloads/?mode=update&version=3.1.3#update

      Maybe i'm in error but it seems the next file is missing: /includes/acp/acp_prune.php

      Because this file has been updated with this: https://github.com/phpbb/phpbb/commit/80e1c233d94c982f13ccbc7ec56b2b8e5381b784

        Activity

        bantu Andreas Fischer added a comment -

        We skip whitespace changes. This is by design.

        nickvergessen Joas Schilling added a comment -

        It's not a whitespace change, it is inside a string! And this fixes a broken sql query, do we need to replace something in the string, like the quotes?

        bantu Andreas Fischer added a comment -

        Maybe it's caused by the code for skipping whitespace changes. Maybe skipping whitespace changes is no longer desirable at all.

        nickvergessen Joas Schilling added a comment -

        I tried and rebuild packages with setting

        	/**
        	* If set to true we trim all lines before we compare them. This ensures that sole space/tab changes do not trigger diffs.
        	*/
        	var $skip_whitespace_changes = true;

        to false. But the file is still not in the package. Seems like the problem is more difficult.


          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            nickvergessen Joas Schilling
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development