Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.13, 3.1.3
    • Fix Version/s: 3.1.4-RC1
    • Component/s: None
    • Labels:
      None

      Description

      We should start running our travis test suite against PHP7 too.

        Issue Links

          Activity

          Hide
          bantu Andreas Fischer added a comment -

          Probably a large problem will be the /e modifier which seems to be no longer supported. I don't think changing 3.0.x to not using the /e modifer is feasible or a good idea.

          Show
          bantu Andreas Fischer added a comment - Probably a large problem will be the /e modifier which seems to be no longer supported. I don't think changing 3.0.x to not using the /e modifer is feasible or a good idea.
          Hide
          nickvergessen Joas Schilling added a comment -

          Is it worth slowing down our test suite with something that is not used in stable productive enviroments atm? :/

          Show
          nickvergessen Joas Schilling added a comment - Is it worth slowing down our test suite with something that is not used in stable productive enviroments atm? :/
          Hide
          nicofuma nicofuma added a comment -

          we coud not support php7 on 3.0.x ...

          for the tests travis just introduced php-nigtly so we can use it to tet against php7

          Show
          nicofuma nicofuma added a comment - we coud not support php7 on 3.0.x ... for the tests travis just introduced php-nigtly so we can use it to tet against php7
          Hide
          Marc Marc added a comment -

          I've tried running tests on travis with PHP 7.0:

          PHP Fatal error:  __clone method called on non-object in /home/travis/build/phpBB3/phpBB/vendor/symfony/browser-kit/Symfony/Component/BrowserKit/History.php on line 108

          Apparently, symfony seems to have some issues with this. I'd just test PHP 7.0 on the master branch for now.

          Show
          Marc Marc added a comment - I've tried running tests on travis with PHP 7.0: PHP Fatal error: __clone method called on non-object in /home/travis/build/phpBB3/phpBB/vendor/symfony/browser-kit/Symfony/Component/BrowserKit/History.php on line 108 Apparently, symfony seems to have some issues with this. I'd just test PHP 7.0 on the master branch for now.
          Hide
          Marc Marc added a comment -

          The PR only adds the PHP 7.0 builds to the 3.1.x and master branch. I don't think we should have it running for phpBB 3.0.

          Show
          Marc Marc added a comment - The PR only adds the PHP 7.0 builds to the 3.1.x and master branch. I don't think we should have it running for phpBB 3.0.
          Hide
          bantu Andreas Fischer added a comment -

          We don't know whether the remaining /e modifiers can be easily removed from 3.1.x, so we are also adding 3.1.x. In the end it might not be possible to easily change 3.1.x to be PHP7 compatible, though.

          Show
          bantu Andreas Fischer added a comment - We don't know whether the remaining /e modifiers can be easily removed from 3.1.x, so we are also adding 3.1.x. In the end it might not be possible to easily change 3.1.x to be PHP7 compatible, though.

            People

            • Assignee:
              Marc Marc
              Reporter:
              naderman Nils Adermann
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development