Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13490

Unicode chars are broken in edit message after preview

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2
    • Fix Version/s: 3.1.3-RC1
    • Component/s: Posting
    • Labels:
      None

      Description

      If you enter an edit message like "Käse" and click on preview, the edit message will be changed to "K??se".

      These chars are handled correctly when posting without preview.
      This bug doesn't occur in 3.0.x

        Issue Links

          Activity

          Senky Senky added a comment -

          Could not reproduce on localhost.

          Elsensee Oliver Schramm added a comment -

          Weird. You entered something like "Käse" as edit message and clicked on preview? The new edit message displayed should then be "K??se"...

          Noxwizard Patrick Webster added a comment -

          @Senky: Put it in the "Reason for editing this message" field, not in the message itself. The phrasing is slightly confusing.

          Senky Senky added a comment -

          I see now. Truly, character's got replaced.


            People

            • Assignee:
              nickvergessen Joas Schilling
              Reporter:
              Elsensee Oliver Schramm
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development