Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13431

wrong margin-left for RTL sites in Internet Explorer mobile view

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0, 3.1.1, 3.1.2
    • Fix Version/s: 3.1.3-RC1
    • Component/s: Styles
    • Labels:
    • Environment:
      RTL (Arabic or Parisian) Sites
      Internet Explorer (Desktop or Windows Phone)
      Width less than 700px or in mobile

      Description

      Page forums list in RTL sites if viewed in Internet Explorer With width less than 700px or viewed in windows mobile phone, The forums list will get wrong margin-left (250px), Only in Internet Explorer.
      same page viewed good in FireFox or Chrome

        Activity

        hubaishan hubaishan added a comment -
        PayBas PayBas added a comment -

        I'm not completely sure, because I couldn't find an answer online. But apparently IE doesn't support nested media queries.

        bidi.css is the only stylesheet where we use nested queries like this: https://github.com/phpbb/phpbb/blob/develop/phpBB/styles/prosilver/theme/bidi.css#L1064

        Notice that the max-width: 550px query is inside the 700px query. The issue is fixed by moving them outside the 700px query.

        hubaishan hubaishan added a comment -

        "The issue is fixed by moving them outside the 700px query."
        This fix the bug with me, now it work good with all browsers

        nickvergessen Joas Schilling added a comment -

        PayBas want to prepare a patch?

        PayBas PayBas added a comment -

        Sure. Just assign it to me.


          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            hubaishan hubaishan
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development