Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13394

When not installed, Sphinx displays succesful search index

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.1.2
    • Fix Version/s: 3.1.13-RC1
    • Component/s: ACP
    • Labels:
      None
    • Environment:
      PHP 5.5.18, PostgreSQL 9.3.5 on x86_64-redhat-linux-gnu (Fedora 20, 64 bit), Firefox 33.1.

      Description

      I do not have the Sphinx search engine installed. For testing purposes, I intentionally selected Sphinx Fulltext as the active search backend (General --> Search Settings).

      I then selected Create Index. Sphinx completed index creation in less than 1 second with the following result:

      Number of posts in main index: 0
      Number of posts in frequently updated delta index: 2076719
      Total number of indexed posts: 2076719

      The total post count is correct.

      I performed a search using the /search.php search engine, which then displayed with the following error:

      Search failed: connection to localhost:9312 failed (errno=101, msg=Network is unreachable)

      The issue is that a site administrator should be presented with an error message inside the ACP. The correct active index can then be selected and the user will not see this error.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Lady_G Lady_G
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: