Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13315

Upgrade from 3.0.12 to 3.1.1 resets CAPTCHA selection

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.1
    • Fix Version/s: 3.1.2-RC1
    • Component/s: Installation system
    • Labels:
      None
    • Environment:
      localhost: PostgreSQL 9.3.5 on x86_64-redhat-linux-gnu (Fedora 20), 64 bit, Firefox 31.0
      Server: PostgreSQL 9.3.5 on x86_64-redhat-linux-gnu, 64-bit, Firefox 31.0

      Description

      After upgrading from 3.0.12 to 3.1.1, my CAPTCHA setting was changed from Q&A to simple image.

      After the upgrade, ACP --> Spambot countermeasures --> Installed plugins: is set to "simple image".

      Changing it back to Q&A restored the configuration (no data was lost).

      I have reproduced this problem on localhost and an online server.

        Issue Links

          Activity

          Lady_G Lady_G added a comment -

          I set the priority as a major bug because it impacts spambot protection.


            People

            • Assignee:
              prototech prototech
              Reporter:
              Lady_G Lady_G
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development