Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13277

Move Up & Down does not take work in Internet Explorer

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0, 3.1.1
    • Fix Version/s: 3.1.2-RC1
    • Component/s: ACP, JavaScript / AJAX
    • Labels:
      None
    • Environment:
      Win 7, Explorer 11, PHP v 5.4.34, MySQL 5.1.66.

      Description

      Move Up & Down dont take effect in Explorer 11 browser & Phpbb 3.1 & 3.1.1
      I have tryed to sort "Forum administration"/ "Board Index" and some categorys.
      And "Users and Groups"/ "Custom Profile Fields"
      It seems not to bee saved.

      It woorks fine in Fire Fox 32.0.3.

        Activity

        prototech prototech added a comment -

        I can't reproduce this using IE11 in Win7.

        SOTAdministratör SOTAdministratör added a comment -

        I restarted my computer and i can reproduce the problem.
        Some times it works a few moves and then suddenly it stops getting "saved" or "locked" in the new position.
        It always looks like its getting moved, but falls back in the old position when you look at the board.

        DavidIQ David Colón added a comment -

        I was experiencing this the other day on phpBB.com when changing the order for the new Extension release forum. Had attributed it to some other weirdness there but evidently that's not the case.

        My VM running Windows 7 and IE 11 has had some slow connectivity issues as of late so that might be the main contributing factor. When I would click on the forum up or down arrows the screen would change the order but the actual order was not being changed. So on the surface it appears that the request is not going through or is timing out while the order on the screen is changed. Since there is an AJAX call here the order changing should be attached to the success portion of the call with a "loading" indicator showing as it appears that this might be happening outside of the AJAX call, although I haven't looked closer at what the forum sort function is doing.

        I'm thinking that another factor here might be the number of forums. We have a LOT of forums (200+) so that might be contributing to the problem, though not sure what the OP has for total number of forums.

        In seeing this problem I checked the ACP system error logs for relevant messages but found nothing. The browser console also has nothing being reported as a JavaScript error or timing out.

        SOTAdministratör SOTAdministratör added a comment -

        Excellent that you've fixed the problem.
        I obviously can still reproduce the problem in 3.1.1
        I cant find a downloadlink to the 3.1.2-RC1 to help you verify the fix.


          People

          • Assignee:
            prototech prototech
            Reporter:
            SOTAdministratör SOTAdministratör
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development