Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13274

Install stalls at Updating Database (3.0.12 -> 3.1.1)

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 3.0.12
    • Fix Version/s: 3.1.2-RC1
    • Component/s: Installation system
    • Labels:
    • Environment:
      PHP version 5.4.32
      MySQL version 5.5.40-36.1
      Host: hostgator shared Linux
      Style: Prosilver
      Firefox 32.0.3 and MSIE (latest) - error occurs on both browsers

      Description

      I am upgrading from 3.0.12 to 3.1.1 and the automated process fails at "Continue database update"


      Updating database to latest stable release

      Database type :: mysql4
      Previous version :: 3.0.12
      Migration already effectively installed (skipped): \phpbb\db\migration\data\v30x\release_3_0_0

      The database update has not yet completed.

      Continue database update

      Clicking on "Continue database update" does nothing. What next?

      If I go to the forum, I see


      General Error
      SQL ERROR [ mysql4 ]

      Table 'dbb_cpps.phpbb_ext' doesn't exist [1146]

      An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

      Ok, so I then followed the alternate instructions for installing, uploading the full 3.1.1 package unmodified (not the config.php file), and left only the images, store and files folders, + config.php, then ran the database update again.

      This time it said


      Updating database to latest stable release

      Database type :: mysql4
      Previous version :: 3.0.12
      Migration already effectively installed (skipped): \phpbb\db\migration\data\v30x\release_3_0_2_rc1
      Migration already effectively installed (skipped): \phpbb\db\migration\data\v30x\release_3_0_2_rc2

      The database update has not yet completed.

      Continue database update

      The first time it said this I hit Continue and it continued for a few seconds, then came back with the abovementioned screen, and this time hitting continue results in a microsecond of activity and then it stops, as per my first message above.

      It seems to be failing on the database update, and I cannot think why. I did have a few extra fields (columns) added to some tables for various mods etc .... can't think why else it would fail.

        Attachments

          Activity

            People

            • Assignee:
              nickvergessen Joas Schilling [X] (Inactive)
              Reporter:
              mamba mamba
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: