Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13241

Topics are being duplicated in multipage forums

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.1.2-RC1
    • Component/s: Viewing forums
    • Labels:
      None

      Description

      If a forum has several pages of topics and also has (global) announcements, topics which located at the half-forum pages will be duplicated from the page right before the end of the 1st forum half to the page right after.

      F.e. if the forum has, say, 2800 pages, topics from the page 1400 will appear at the page 1401, and so on.

      The number of duplicated topics is equal to the number of the (global) announcements.

      See the screenshots from the .com board.

      1. phpbb-1.jpg
        185 kB
      2. phpbb-2.jpg
        203 kB

        Activity

        nickvergessen Joas Schilling added a comment -

        Shortest solution to reproduce:
        Forum 1: 6 topics
        Forum 2: 1 GA

        Topics per pages: 4

        Expected:
        Page 1: Topic 1-4
        Page 2: Topic 5+6

        Actual:
        Page 1: Topic 1-4
        Page 2: Topic 4-6

        Also discovered another bug which is caused by the GA:
        Topics per pages: 3

        Expected:
        2 Pages with 3 topics each

        Actual:
        Pagination shows 3 pages


          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            rxu Ruslan Uzdenov
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development