Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-13239

Can´t upload Attachments on iOS

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.1.2-RC1
    • Component/s: Posting
    • Labels:
      None

      Description

      I can´t upload Attachments from my iPod touch 4G with iOS 6.1.6 on the phpBB.com Community.

        Activity

        Hide
        Marshalrusty Yuriy Rusko added a comment -

        Hi jacboy,

        Did you mean phpBB.com or are you actually talking about the MyBB community? They're an entirely separate organization using different software.

        Show
        Marshalrusty Yuriy Rusko added a comment - Hi jacboy, Did you mean phpBB.com or are you actually talking about the MyBB community? They're an entirely separate organization using different software.
        Hide
        jacboy jacboy added a comment -

        Grrrr,

        i was MyBB user for... one or two years.
        Its just a tyo

        Show
        jacboy jacboy added a comment - Grrrr, i was MyBB user for... one or two years. Its just a tyo
        Hide
        DavidIQ David Colón added a comment -

        This is a problem with the plupload plugin when viewing a 3.1 forum using iOS. The easiest fix seems to be to force single file selection in the case of mobile browsing or at least for iOS.

        Related: http://www.plupload.com/punbb/viewtopic.php?id=2376

        Show
        DavidIQ David Colón added a comment - This is a problem with the plupload plugin when viewing a 3.1 forum using iOS. The easiest fix seems to be to force single file selection in the case of mobile browsing or at least for iOS. Related: http://www.plupload.com/punbb/viewtopic.php?id=2376
        Hide
        prototech prototech added a comment -

        The issue that David mentioned is addressed in Plupload itself. In our case, because the button is hidden on load, Plupload can't determine the correct location of the "Add files" button. So, we have to refresh the plupload instance once the button is visible so that the position gets recalculated.

        Also for reference: https://www.phpbb.com/community/viewtopic.php?f=466&t=2269746

        Show
        prototech prototech added a comment - The issue that David mentioned is addressed in Plupload itself. In our case, because the button is hidden on load, Plupload can't determine the correct location of the "Add files" button. So, we have to refresh the plupload instance once the button is visible so that the position gets recalculated. Also for reference: https://www.phpbb.com/community/viewtopic.php?f=466&t=2269746
        Hide
        DavidIQ David Colón added a comment -

        On a related note I've applied the patch to my live 3.1 forum and can verify that it indeed fixes the issue. Nice work.

        Show
        DavidIQ David Colón added a comment - On a related note I've applied the patch to my live 3.1 forum and can verify that it indeed fixes the issue. Nice work.

          People

          • Assignee:
            prototech prototech
            Reporter:
            jacboy jacboy
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development