Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12975

Catchable fatal error after update to RC3

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-RC3
    • Fix Version/s: 3.1.0-RC4
    • Component/s: Authentication
    • Labels:
      None
    • Environment:
      PHP 5.4.31, MySQL 5.5.37-cll, FF 31.0
      installed extensions: [BETA] Advanced BBCode Box 3.1, [RC] Board Announcements, [BETA] Board Rules Extension,
      prosilver based style (updated 2014-08-09)

      Description

      After successful update from phpBB 3.1.0 RC2 to RC 3 when I try to log in to my forum I get following error:

      Catchable fatal error: Argument 6 passed to phpbb\auth\provider\db::__construct() must implement interface Symfony\Component\DependencyInjection\ContainerInterface, string given, called in /xxx/xxx/xxx/forum1_phpBB31/phpbb/auth/provider/oauth/oauth.php on line 163 and defined in /xxx/xxx/xxx/forum1_phpBB31/phpbb/auth/provider/db.php on line 48

        Issue Links

          Activity

          Hide
          leschek leschek added a comment - - edited

          Edit: Seems that I made some error copying line 55 in phpBB/config/auth_providers.yml (in notepad++). Now it seems to be fixed.

          Show
          leschek leschek added a comment - - edited Edit: Seems that I made some error copying line 55 in phpBB/config/auth_providers.yml (in notepad++). Now it seems to be fixed.
          Hide
          Volksdevil Volksdevil added a comment - - edited

          At which page do you get that error lescheck? Did you use a good file editor?
          EDIT: Ah, seems all good!

          Show
          Volksdevil Volksdevil added a comment - - edited At which page do you get that error lescheck? Did you use a good file editor? EDIT: Ah, seems all good!
          Hide
          wintstar wintstar added a comment -

          The same bug is in 3.2.0-a1-dev.

          Show
          wintstar wintstar added a comment - The same bug is in 3.2.0-a1-dev.
          Hide
          Volksdevil Volksdevil added a comment -

          @Nicofuma, it seems the two file edits do solve the issue for RC3 at least.

          Show
          Volksdevil Volksdevil added a comment - @Nicofuma, it seems the two file edits do solve the issue for RC3 at least.
          Hide
          wintstar wintstar added a comment -

          The patch works. When it is inserted?

          Show
          wintstar wintstar added a comment - The patch works. When it is inserted?

            People

            • Assignee:
              nicofuma nicofuma
              Reporter:
              leschek leschek
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development