Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12895

?style=1 appended to url after using the UCP

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev, 3.1.0-RC2
    • Fix Version/s: 3.1.0-RC3
    • Labels:
      None

      Description

      This can be experienced on Area51 to test it out.

      Go to the UCP Board Preferences and just click submit. Then leave the UCP (go to board index, for example) and you will see ?style=1 has been appended to the URL.

        Activity

        Hide
        Volksdevil Volksdevil added a comment -

        Yep. Happens for me on area51, but strangely not on my RC2 test board.

        Although I am testing the following extensions if it helps:
        Board Announcements
        Board Rules
        Breadcrumb Menu
        Browse Happy
        Lightbox
        phpBB 3.1 Post Love
        Quick Ads
        Quickedit
        Quick Login
        Share On
        Topic Preview

        I guess it would be better tested on a clean install, but just thought I'd pop a reply here just in case it helps.

        Show
        Volksdevil Volksdevil added a comment - Yep. Happens for me on area51, but strangely not on my RC2 test board. Although I am testing the following extensions if it helps: Board Announcements Board Rules Breadcrumb Menu Browse Happy Lightbox phpBB 3.1 Post Love Quick Ads Quickedit Quick Login Share On Topic Preview I guess it would be better tested on a clean install, but just thought I'd pop a reply here just in case it helps.
        Hide
        VSE Matt Friedman added a comment -

        Happens to me on area51 and my test boards (RC2 and branch of the latest version of the dev branch).

        Show
        VSE Matt Friedman added a comment - Happens to me on area51 and my test boards (RC2 and branch of the latest version of the dev branch).
        Hide
        Marc Marc added a comment - - edited

        This only happens if more than one style is installed and more than one style is active btw.

        edit: append_sid() is adding the style parameter.

        Show
        Marc Marc added a comment - - edited This only happens if more than one style is installed and more than one style is active btw. edit: append_sid() is adding the style parameter.

          People

          • Assignee:
            Marc Marc
            Reporter:
            VSE Matt Friedman
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development