Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12764

Wrong error message on install if mysqli is selected and the credentials are wrong

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-RC1
    • Fix Version/s: 3.1.0-RC2
    • Component/s: Installation system
    • Labels:
      None

      Description

      I got

      The version of MySQL installed on this machine is incompatible with the “MySQL with MySQLi Extension” option you have selected. Please try the “MySQL” option instead.
      

      instead of

      Could not connect to the database, see error message below.
      Access denied for user 'root'@'localhost' (using password: YES)
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Marc Marc
                Reporter:
                nicofuma nicofuma
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: