Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12760

Post approval icon for wrong topics in Last Post column

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-b4
    • Fix Version/s: 3.1.0-RC2
    • Component/s: None
    • Labels:
      None

      Description

      When viewing the list of forums, the Last Post column will wrongly show the Post Needs Approval Icon next to the name of any topic, even if the topic title shown in the Last Post column is not the topic that has unapproved posts.

      The unapproved posts icon should only be shown if the topic title shown in the last post column has unapproved posts.

      Reproduce:
      Create a topic with a post needing approval inside it.
      Create a newer topic (with no posts needing approval).
      View forums and you will see the new topic in the Last Post column presenting the icon as if it had unapproved posts.

        Activity

        nickvergessen Joas Schilling added a comment -

        The idea of the icon is to inform moderators about the status of the forum, not just one topic.
        It's already done like that in 3.0 for unapproved topics btw.

        So if at all, we should move the icon/info away from "last post", but it should still contain the information about the forum.

        VSE Matt Friedman added a comment - - edited

        Also the problem is on mouse over it says "At least one post in this topic has not been approved", which could be false for the topic actually shown.

        VSE Matt Friedman added a comment -

        It could just be changed to say "At least one post in this forum has not been approved"

        nickvergessen Joas Schilling added a comment -

        Yes, this is basically a language failure and should be fixed as such.


          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            VSE Matt Friedman
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development