Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12682

Code Sniffer does not work correctly on Travis CI.

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-RC1
    • Component/s: None
    • Labels:
      None

      Description

      It seems that Code Sniffer finds some things only when run locally, which seems rather weird. This needs investigation.

        Activity

        Hide
        Marc Marc added a comment -

        The last issues actually didn't pop up on my local branch either but rather while running the tests on my extension: https://travis-ci.org/board3/Board3-Portal/jobs/27093043

        Show
        Marc Marc added a comment - The last issues actually didn't pop up on my local branch either but rather while running the tests on my extension: https://travis-ci.org/board3/Board3-Portal/jobs/27093043
        Show
        Marc Marc added a comment - - edited Another issue that slipped through: https://travis-ci.org/board3/Board3-Portal/jobs/27315892#L711 Link to github blame page: https://github.com/phpbb/phpbb/blame/develop-ascraeus/phpBB/includes/acp/acp_groups.php#L516

          People

          • Assignee:
            bantu Andreas Fischer
            Reporter:
            bantu Andreas Fischer
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development