Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12667

New posts in a topic cause undesirable results when clicking topic title or page button

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-b4
    • Fix Version/s: 3.1.0-RC1
    • Component/s: Viewing posts
    • Labels:
      None

      Description

      See http://area51.phpbb.com/phpBB/viewtopic.php?f=81&t=45727

      Steps to reproduce:
      1) Pick a topic with new posts (the new posts must be on a page with posts you have already read)
      2) Click on the topic title
      3) If the topic is only 1 page, it will jump to the new posts (it should go to the first post)
      4) If the topic spans multiple pages, it will jump to the first post in the topic (expected behavior). Clicking on the last page (again, with posts that you have already read) will jump to the new posts (unexpected behavior - it should jump to the first post for that page).

      If you need a screen video, let me know and I'll create one tonight or tomorrow and upload it somewhere.

        Issue Links

          Activity

          Hide
          VSE Matt Friedman added a comment - - edited

          Caused by: https://github.com/phpbb/phpbb/pull/2414

          I was able to reproduce.
          The link when hovering over it with the mouse was: https://area51.phpbb.com/phpBB/viewtopic.php?f=81&t=45717
          But the resulting page url after clicking it was: https://area51.phpbb.com/phpBB/viewtopic.php?p=265155#p265155

          Why was the page I ended up at not the same URL as the link I clicked on? How did f=X&t=X transform into p=x#pX ??

          Once the topic is considered "read", clicking on the topic title returns to normal, that is, the resulting page url is the same as the url of the topic title I clicked on.

          This brings back the unpleasantness from before, where clicking on a topic title takes you anywhere but where it should - the first post!

          Show
          VSE Matt Friedman added a comment - - edited Caused by: https://github.com/phpbb/phpbb/pull/2414 I was able to reproduce. The link when hovering over it with the mouse was: https://area51.phpbb.com/phpBB/viewtopic.php?f=81&t=45717 But the resulting page url after clicking it was: https://area51.phpbb.com/phpBB/viewtopic.php?p=265155#p265155 Why was the page I ended up at not the same URL as the link I clicked on? How did f=X&t=X transform into p=x#pX ?? Once the topic is considered "read", clicking on the topic title returns to normal, that is, the resulting page url is the same as the url of the topic title I clicked on. This brings back the unpleasantness from before, where clicking on a topic title takes you anywhere but where it should - the first post!
          Hide
          nickvergessen Joas Schilling added a comment -

          Caused by https://tracker.phpbb.com/browse/PHPBB3-12440

          I guess we should only set

           data-url="{postrow.U_MINI_POST}"

          when the view=unread URL thingy was used

          Show
          nickvergessen Joas Schilling added a comment - Caused by https://tracker.phpbb.com/browse/PHPBB3-12440 I guess we should only set data-url="{postrow.U_MINI_POST}" when the view=unread URL thingy was used

            People

            • Assignee:
              prototech prototech
              Reporter:
              tmbackoff Tabitha Backoff [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development