Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12326

Error while updating from b1 to b2 because of incomplete update files

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-b1
    • Fix Version/s: 3.1.0-b2
    • Component/s: Update system
    • Labels:
      None

      Description

      If you try to update from 3.1.0-b1 to 3.1.0-b2 you get an error:

      General Error
      The update files are incomplete.
       
      BACKTRACE
       
      FILE: (not given by php)
      LINE: (not given by php)
      CALL: msg_handler()
       
      FILE: /install/install_update.php
      LINE: 1295
      CALL: trigger_error()
       
      FILE: /install/install_update.php
      LINE: 376
      CALL: install_update->get_update_structure()
       
      FILE: /install/index.php
      LINE: 386
      CALL: install_update->main()
       
      FILE: /install/index.php
      LINE: 263
      CALL: module->load()
      

        Activity

        nickvergessen Joas Schilling added a comment - - edited

        This is due to deleted files being named in the diff as all content replace with nothing.
        The script extracting the file names does not check for this case.
        However, it is strang that this is reproducable on b1>b2, but not on 3.0.12>b2 although the same file is listed incorrectly in both packages


          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            Elsensee Oliver Schramm
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development