Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12294

phpbb_ in profile fields column names is incorrectly replaced with the table prefix

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-b1
    • Fix Version/s: 3.1.0-b2
    • Component/s: Installation system
    • Labels:
    • Environment:
       PHP 5.2.3, MySQL 5.1.3, IE11

      Description

      When using a different table_prefix profile fields are still with prefix phpbb.
      Data fields are with the other prefix.
      It's not possible to update / insert the fields in this way

        Issue Links

          Activity

          nickvergessen Joas Schilling added a comment -

          No the "phpbb_" in column names should not be replaced with the table prefix. It's a bug, we will change it, just wait for the fix please.

          bantu Andreas Fischer added a comment - - edited

          Field names are not supposed to use a table prefix at all. This is the root cause of the problem you are reporting here. The phpbb_ prefix seems to be used as a vendor prefix.

          John P John P added a comment -

          Ok, so it's stays pf_fieldname.
          I will throw away the b1 update

          nickvergessen Joas Schilling added a comment -
          nickvergessen Joas Schilling added a comment -

          Fixed as per comment above


            People

            • Assignee:
              nickvergessen Joas Schilling
              Reporter:
              John P John P
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development