Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a3, 3.1.0-b1
    • Component/s: Search, Test Suite
    • Labels:
      None

      Description

      1) phpbb_functional_search_mysql_test::test_search_backend

      Failed asserting that 502 matches expected 200.

      /home/travis/build/phpbb/phpbb/tests/test_framework/phpbb_functional_test_case.php:779

      /home/travis/build/phpbb/phpbb/tests/test_framework/phpbb_functional_test_case.php:738

      /home/travis/build/phpbb/phpbb/tests/test_framework/phpbb_functional_test_case.php:97

      /home/travis/build/phpbb/phpbb/tests/functional/search/base.php:35

      Fails on MySQL, Postgres and MariaDB, so likely to be a PHP issue rather than MySQL related. Started to fail after travis updated their images.

        Activity

        Hide
        nickvergessen Joas Schilling added a comment -

        Okay after some investigation prototech and me found out, that the sphinx class is causing this problem.
        Although we only set things up and do not contact the server, it seems to do that and thereby tries to contact the non existing server.

        Why does this only happen on php 5.5 and only for mysql and postgres? I don't know.

        Show
        nickvergessen Joas Schilling added a comment - Okay after some investigation prototech and me found out, that the sphinx class is causing this problem. Although we only set things up and do not contact the server, it seems to do that and thereby tries to contact the non existing server. Why does this only happen on php 5.5 and only for mysql and postgres? I don't know.
        Hide
        nickvergessen Joas Schilling added a comment -

        okay so this issue is caused by some stuff from php-fpm, preg_match together with assert(0 && "string longer then 3 chars") in 2 different files.
        Nils is investigating, but most likely its a php-bug.

        Show
        nickvergessen Joas Schilling added a comment - okay so this issue is caused by some stuff from php-fpm, preg_match together with assert(0 && "string longer then 3 chars") in 2 different files. Nils is investigating, but most likely its a php-bug.
        Hide
        nickvergessen Joas Schilling added a comment -

        Nils Adermann can we close this now, as it is some php fpm fail?
        It's the last blocker for 3.1-a3

        Show
        nickvergessen Joas Schilling added a comment - Nils Adermann can we close this now, as it is some php fpm fail? It's the last blocker for 3.1-a3
        Hide
        bantu Andreas Fischer added a comment -

        No, I'll fix it now.

        Show
        bantu Andreas Fischer added a comment - No, I'll fix it now.
        Hide
        bantu Andreas Fischer added a comment -
        Show
        bantu Andreas Fischer added a comment - For reference: https://github.com/travis-ci/travis-ci/issues/1922
        Hide
        nickvergessen Joas Schilling added a comment -

        php was updated to 5.5.8 on travis and now the bug occures again on travis. Seems like https://github.com/phpbb/phpbb/blob/develop/travis/setup-php-extensions.sh#L41 needs further adjustments

        Show
        nickvergessen Joas Schilling added a comment - php was updated to 5.5.8 on travis and now the bug occures again on travis. Seems like https://github.com/phpbb/phpbb/blob/develop/travis/setup-php-extensions.sh#L41 needs further adjustments

          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            naderman Nils Adermann
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development