Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-12049

PLUPLOAD_ERR_UPLOAD_LIMIT should be using plurals

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-a2
    • Fix Version/s: 3.1.0-a3
    • Component/s: Language pack
    • Labels:
      None

      Description

      'PLUPLOAD_ERR_UPLOAD_LIMIT' => 'Upload element accepts only %d file(s) at a time. Extra files were stripped.',

      it should not be so

      'PLUPLOAD_ERR_UPLOAD_LIMIT' => array(
      1 => 'Upload element accepts only %d file at a time. Extra files were stripped.',
      2 => 'Upload element accepts only %d files at a time. Extra files were stripped.',
      ),

        Issue Links

          Activity

          nickvergessen Joas Schilling added a comment -

          The problem is, that plupload does not really use plurals. We just specify the strings. The numbers are replaced by plupload not by us. So I'm not sure whether we can do anything about it at all.

          wintstar wintstar added a comment -

          So far, it is in 3.0.12 everything is to be translated. In my opinion that should be in 3.1. too. I would not find it good if it were not possible. I still noticed these are some error messages do not translate.

          wintstar wintstar added a comment -

          Fixed with Build 1220


            People

            • Assignee:
              nickvergessen Joas Schilling
              Reporter:
              wintstar wintstar
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development